Evanescent Thoughts

Evanescent Thoughts

gstreamer bug in Ubuntu and a temporary fix

with 5 comments


Off late I found that some of the movies that I downloaded from the internet played really wierd . The quality of the movie was good but the colors seem to be distorted and there used to be a green band . Look at the pics below . The one in the left is how the actual movie is supposed to be and the one in the right is how it appears.

vlcsnap-461622screenshot-madagascar-2avi-vlc-media-player3

Few things I tried out to fix this :

1. I thought it was the problem with the video i downloaded because not all videos had this prolem . So I tried using mencoder to convert to other formats and fix the video . Didn’t work 😦

2. Tried re-downloading and changing my torrent managers . Miserably failed 😦

3. Tried playing in all sorts of different player . All of them had the same problem . Now I was sure it was not a problem with the codecs used nor the player.

4. Booted in windows and tried playing . Worked perfectly fine. So I was sure the problem was still with Linux .

In the mean time I had deleted a couple of movies because I really got irritated because of the problem .

This is when  googling struck me and I found out about the gstreamer bug .  GStreamer is a library for constructing graphs of media-handling components. The applications it supports range from simple Ogg/Vorbis playback, audio/video streaming to complex audio (mixing) and video (non-linear editing) processing.

Tried meddling with the properties of gstreamer from the command line . No effect 😦

Finally did the following

sudo apt-get remove totem-gstreamer

sudo apt-get install totem-xine gxine

Yippe !!! All videos worked fine with the new players using the xine engine 🙂 . I hope they get to the bug fix soon . Mean while you can log your complaints at http://bugzilla.gnome.org/show_bug.cgi?id=357741  and please mention any fixes you get to know . One of them involving changing gstreamer properties seems to work for some .

Advertisements

Written by Sathya Narayanan

March 11, 2009 at 1:44 am

5 Responses

Subscribe to comments with RSS.

  1. Thank you so much 🙂

    You really don’t know how many movies I deleted thinking that there was some problem with the download. 😦

    sp2hari

    March 11, 2009 at 1:54 am

  2. I deleted one yesterday 😦 . Actually I changed my torrent managers and all to see if tht was the prob 😛

    Sathya Narayanan

    March 11, 2009 at 2:02 am

  3. Hi, According to that bug report you pointed to, it looks like a ATI driver bug and not a GStreamer bug. Or are the fglrx drivers failing *again* ?

    It would be good to point that out in your blog post.

    bilboed

    March 11, 2009 at 1:07 pm

    • @bilboed : yeah tht bug report is for ATI drivers . But mine is a nvidia driver . And I still had the prob.. I still think its a prob with gstreamer . cos whn i played in totem-gstreamer it didnt work bt totem-xine worked . Lets wait n see 🙂

      Sathya Narayanan

      March 11, 2009 at 1:18 pm

  4. […] gstreamer bug in Ubuntu and a temporary fix […]


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: